Back to overview
Downtime
Email API - Amazon
Aug 01 at 05:24pm CEST
Affected services
Amazon
Resolved
May 31 at 04:41pm CEST
Amazon email check is now operational.
Affected services
Amazon
Created
Aug 01 at 05:24pm CEST
Amazon email check is currently down. The team is working on fixing the issue.
Affected services
Amazon