Back to overview
Downtime

Email API - Xing

Mar 13 at 11:17am CET
Affected services
Xing

Resolved
Mar 19 at 02:57pm CET

Xing email check is now operational.

Created
Mar 13 at 11:17am CET

Xing email check is currently unavailable. Our team is actively addressing the issue.