Back to overview
Downtime

Email & Phone API - Google

Apr 10 at 09:56pm CEST
Affected services
Google
Google (Phone)

Resolved
Apr 11 at 02:47pm CEST

Google email and phone checks are now operational and available to all customers.

Created
Apr 10 at 09:56pm CEST

Google phone and email checks are currently unavailable. Our team is actively addressing the issue.