Back to overview
Downtime

Email API - Chess

Jan 13 at 12:00pm CET
Affected services
Chess

Resolved
Mar 07 at 09:41am CET

Chess email check is now operational.

Created
Jan 13 at 12:00pm CET

Chess email check is currently unavailable. Our team is actively addressing the issue.