Back to overview
Downtime

Email API - Hubspot

Jan 17 at 08:00pm CET
Affected services
Hubspot

Resolved
Jan 23 at 09:16am CET

Hubspot email check is now operational.

Created
Jan 17 at 08:00pm CET

Hubspot email check is currently unavailable. Our team is actively addressing the issue.