Back to overview
Downtime

Email API - Imgur

Oct 11, 2024 at 11:00am UTC
Affected services
Imgur

Resolved
Mar 12, 2025 at 12:57pm UTC

Imgur email check is now operational.

Created
Oct 11, 2024 at 11:00am UTC

Imgur email check is currently unavailable. Our team is actively addressing the issue.