Back to overview
Downtime

Phone API - Shopclues

Jan 27 at 11:03pm CET
Affected services
Shopclues (Phone)

Resolved
Jan 29 at 01:21pm CET

Shopclues phone check is now operational.

Created
Jan 27 at 11:03pm CET

Shopclues phone check is currently unavailable. Our team is actively addressing the issue.