Back to overview
Downtime
Email API - Hubspot
Jan 29, 2025 at 10:52pm UTC
Affected services
Hubspot
Resolved
Feb 19, 2025 at 11:20am UTC
Hubspot email check is now operational.
Affected services
Created
Jan 29, 2025 at 10:52pm UTC
Hubspot email check is currently unavailable. Our team is actively addressing the issue.
Affected services