Back to overview
Downtime

Email API - Cashapp

Feb 15 at 04:15pm CET
Affected services
Cashapp

Resolved
Mar 05 at 09:37am CET

Cashapp email check is now operational.

Created
Feb 15 at 04:15pm CET

Cashapp email check is currently unavailable. Our team is actively addressing the issue.