Back to overview
Downtime
Email API - Hubspot
Mar 07 at 10:10am CET
Affected services
Hubspot
Resolved
Mar 14 at 04:16pm CET
Hubspot email check is now operational.
Affected services
Hubspot
Created
Mar 07 at 10:10am CET
Hubspot email check is currently unavailable. Our team is actively addressing the issue.
Affected services
Hubspot