Back to overview
Downtime
Email API - Indiamart
Mar 7, 2025 at 4:28pm UTC
Affected services
Indiamart
Resolved
Mar 18, 2025 at 11:55am UTC
Indiamart email check is now operational.
Affected services
Created
Mar 7, 2025 at 4:28pm UTC
Indiamart email check is currently unavailable. Our team is actively addressing the issue.
Affected services