Back to overview
Downtime

Email API - Momoshop

Mar 11 at 09:42am CET
Affected services
Momoshop

Resolved
Apr 07 at 01:39pm CEST

Momoshop email check is now operational.

Created
Mar 11 at 09:42am CET

Momoshop email check is currently unavailable. Our team is actively addressing the issue.