Back to overview
Downtime

Email API - Simpcity

Apr 07 at 02:41pm CEST
Affected services
Simpcity

Resolved
Apr 08 at 10:00am CEST

Simpcity email check is now operational.

Created
Apr 07 at 02:41pm CEST

Simpcity email check is currently unavailable. Our team is actively addressing the issue.