Back to overview
Downtime

Email API - Monday

Apr 16 at 11:41am CEST
Affected services
Monday

Resolved
May 05 at 02:04pm CEST

Monday email check is now operational.

Updated
Apr 29 at 12:57pm CEST

Monday email check is currently unavailable. Our team is actively addressing the issue

Created
Apr 16 at 11:41am CEST

Monday email check is currently unavailable. Our team is actively addressing the issue.