Back to overview
Downtime

Email API - Samsung

May 13 at 07:23pm CEST
Affected services
Samsung

Resolved
May 22 at 04:13pm CEST

Samsung email check is now operational.

Created
May 13 at 07:23pm CEST

Samsung email check is currently unavailable. Our team is actively addressing the issue.