Back to overview
Downtime

Email API - Pinterest

May 14, 2025 at 11:10pm UTC
Affected services
Pinterest

Resolved
May 15, 2025 at 8:25am UTC

Pinterest email check is now operational.

Created
May 14, 2025 at 11:10pm UTC

Pinterest email check is currently unavailable. Our team is actively addressing the issue.