Back to overview
Downtime

Email API - Simpcity

May 23 at 03:46pm CEST
Affected services
Simpcity

Resolved
May 27 at 11:16am CEST

Simpcity email check is now operational.

Created
May 23 at 03:46pm CEST

Simpcity email check is currently unavailable. Our team is actively addressing the issue.