Back to overview
Downtime

Phone API - Betway

Jun 6, 2025 at 9:09am UTC
Affected services
Betway

Resolved
Jun 17, 2025 at 1:44pm UTC

Betway phone check is now operational.

Created
Jun 6, 2025 at 9:09am UTC

Betway phone check is currently unavailable. Our team is actively addressing the issue.