Back to overview
Downtime

Email API - Betfair

Jun 11 at 01:44pm CEST
Affected services
Betfair

Resolved
Jun 16 at 02:04pm CEST

Betfair email check is now operational.

Created
Jun 11 at 01:44pm CEST

Betfair email check is currently unavailable. Our team is actively addressing the issue.