Back to overview
Downtime

Email API - Sporcle

Jul 28, 2025 at 10:15am UTC
Affected services
Sporcle

Updated
Jul 29, 2025 at 2:19pm UTC

Sporcle email check is currently unavailable. Our team is actively addressing the issue.

Updated
Jul 28, 2025 at 11:34am UTC

Sporcle email check is now operational.

Created
Jul 28, 2025 at 10:15am UTC

Sporcle email check is currently unavailable. Our team is actively addressing the issue.