Back to overview
Downtime
Email API - Vistaprint
Aug 11 at 11:09am CEST
Affected services
Vistaprint
Updated
Aug 15 at 09:36pm CEST
Vistaprint email check is currently unavailable. Our team is actively addressing the issue.
Affected services
Vistaprint
Updated
Aug 13 at 11:22am CEST
Vistaprint email check is now operational.
Affected services
Vistaprint
Updated
Aug 12 at 12:36pm CEST
Vistaprint email check is currently unavailable. Our team is actively addressing the issue.
Affected services
Vistaprint
Updated
Aug 11 at 11:55am CEST
Vistaprint email check is now operational.
Affected services
Vistaprint
Created
Aug 11 at 11:09am CEST
Vistaprint email check is currently unavailable. Our team is actively addressing the issue.
Affected services
Vistaprint