Back to overview
Downtime
Email API - Betcris
Aug 22, 2025 at 10:00am UTC
Affected services
Betcris
Resolved
Aug 26, 2025 at 09:45am UTC
Betcris email check is now operational.
Affected services
Created
Aug 22, 2025 at 10:00am UTC
Betcris email check is currently unavailable. Our team is actively addressing the issue.
Affected services