Back to overview
Downtime

Phone API - Careem

Aug 23, 2025 at 11:08am UTC
Affected services
Careem

Resolved
Sep 05, 2025 at 08:59am UTC

Careem phone check is now operational.

Created
Aug 23, 2025 at 11:08am UTC

Careem phone check is currently unavailable. Our team is actively addressing the issue.