Back to overview
Downtime
Email API - Khanacademy
Aug 26 at 11:44am CEST
Affected services
Khanacademy
Resolved
Sep 01 at 11:02am CEST
Khanacademy email check is now operational.
Affected services
Created
Aug 26 at 11:44am CEST
Khanacademy email check is currently unavailable. Our team is actively addressing the issue.
Affected services