Back to overview
Downtime
Email API - Monday
Sep 12, 2025 at 09:39pm UTC
Affected services
Monday
Resolved
Sep 16, 2025 at 09:32am UTC
Monday email check is now operational.
Affected services
Created
Sep 12, 2025 at 09:39pm UTC
Monday email check is currently unavailable. Our team is actively addressing the issue.
Affected services