Back to overview
Downtime

Email API - Pinterest

Sep 24 at 08:51pm CEST
Affected services
Pinterest

Resolved
Oct 07 at 03:28pm CEST

Pinterest email check is now operational.

Created
Sep 24 at 08:51pm CEST

Pinterest email check is currently unavailable. Our team is actively addressing the issue.