Back to overview
Downtime

Email API - Betfair

Sep 25 at 08:17pm CEST
Affected services
Betfair

Resolved
Sep 26 at 02:09pm CEST

Betfair email check is now operational.

Created
Sep 25 at 08:17pm CEST

Betfair email check is currently unavailable. Our team is actively addressing the issue.