Back to overview
Downtime

Email API - Picsart

Sep 25 at 08:21pm CEST
Affected services
Picsart

Resolved
Sep 29 at 11:00am CEST

Picsart email check is now operational.

Created
Sep 25 at 08:21pm CEST

Picsart email check is currently unavailable. Our team is actively addressing the issue.