Back to overview
Downtime

Email API - Microsoft Teams

Sep 28 at 06:55am CEST
Affected services
Microsoft Teams

Resolved
Sep 30 at 05:00pm CEST

Microsoft Teams email check is now operational.

Created
Sep 28 at 06:55am CEST

Microsoft Teams email check is currently unavailable. Our team is actively addressing the issue.