Back to overview
Downtime

Email API - Picsart

Sep 29 at 11:09pm CEST
Affected services
Picsart

Resolved
Oct 07 at 03:25pm CEST

Picsart email check is now operational.

Created
Sep 29 at 11:09pm CEST

Picsart email check is currently unavailable. Our team is actively addressing the issue.