Back to overview
Downtime
Emal API - Betfair
Oct 01 at 06:42am CEST
Affected services
Betfair
Resolved
Oct 03 at 05:35pm CEST
Betfair email check is now operational.
Affected services
Created
Oct 01 at 06:42am CEST
Betfair email check is currently unavailable. Our team is actively addressing the issue.
Affected services