Back to overview
Downtime

Email API - Betfair

Oct 10, 2025 at 04:55am UTC
Affected services
Betfair

Resolved
Oct 13, 2025 at 01:34pm UTC

Betfair email check is now operational.

Created
Oct 10, 2025 at 04:55am UTC

Betfair email check is currently unavailable. Our team is actively addressing the issue.