Back to overview
Downtime

Email API - Intercom

Nov 12, 2025 at 11:29am UTC
Affected services
Intercom

Resolved
Apr 28, 2026 at 12:06pm UTC

Intercom email check is now operational.

Created
Nov 12, 2025 at 11:29am UTC

Intercom email check is currently unavailable. Our team is actively addressing the issue.