Back to overview
Downtime
Email API - Coppel
Nov 19 at 02:57pm CET
Affected services
Coppel
Created
Nov 19 at 02:57pm CET
Coppel email check is currently unavailable. Our team is actively addressing the issue.
Affected services
Created
Nov 19 at 02:57pm CET
Coppel email check is currently unavailable. Our team is actively addressing the issue.
Affected services