Back to overview
Downtime
Email API - Bayut
Dec 08, 2025 at 10:54am UTC
Affected services
Bayut
Resolved
Dec 18, 2025 at 03:20pm UTC
Bayut email check is now operational.
Affected services
Created
Dec 08, 2025 at 10:54am UTC
Bayut email check is currently unavailable. Our team is actively addressing the issue.
Affected services