Back to overview
Downtime

Email API - Kucoin

Dec 19 at 12:24am CET
Affected services
Kucoin

Resolved
Jan 06 at 02:37pm CET

Kucoin email check is now operational.

Created
Dec 19 at 12:24am CET

Kucoin email check is currently unavailable. Our team is actively addressing the issue.