Back to overview
Degraded
Email API - Amazon
Jan 15, 2026 at 08:40am UTC
Affected services
Amazon
Resolved
Jan 19, 2026 at 12:03pm UTC
Amazon email check is now operational.
Affected services
Created
Jan 15, 2026 at 08:40am UTC
Amazon email check is currently operating with an elevated null rate. Our team is actively addressing the issue.
Affected services