Back to overview
Downtime

Emai API - Google

Feb 16, 2026 at 8:41am UTC
Affected services
Google

Updated
Mar 4, 2026 at 1:17pm UTC

Google email check is currently operating with an elevated null rate. For more details, please reach out to support@seon.io.

Created
Feb 16, 2026 at 8:41am UTC

Google email check is currently unavailable. Our team is actively addressing the issue.