Back to overview
Downtime

Emaiil API - Google Calendar

Feb 16, 2026 at 8:42am UTC
Affected services
Google Calendar

Resolved
Mar 23, 2026 at 1:31pm UTC

Google Calendar email check is now operational.

Created
Feb 16, 2026 at 8:42am UTC

Google Calendar email check is currently unavailable. Our team is actively addressing the issue.