Back to overview
Downtime
Phone API - Irctc
Feb 16, 2026 at 8:16pm UTC
Affected services
Irctc (Phone)
Resolved
Mar 12, 2026 at 2:40pm UTC
Irctc phone enrichment is now operational and available to all customers.
Affected services
Created
Feb 16, 2026 at 8:16pm UTC
Irctc phone check is currently unavailable. Our team is actively addressing the issue.
Affected services