Back to overview
Downtime
Email API - Mail
Mar 2, 2026 at 4:30pm UTC
Affected services
Mail
Resolved
Apr 13, 2026 at 9:08am UTC
Mail email check is now operational.
Affected services
Created
Mar 2, 2026 at 4:30pm UTC
Mail email check is currently unavailable. Our team is actively addressing the issue.
Affected services