Back to overview
Downtime
Email API - Redfin
Mar 6, 2026 at 10:22am UTC
Affected services
Redfin
Resolved
Mar 12, 2026 at 2:42pm UTC
Redfin email check is now operational and available to all customers.
Affected services
Created
Mar 6, 2026 at 10:22am UTC
Redfin email check is currently unavailable. Our team is actively addressing the issue.
Affected services