Back to overview
Downtime

Email API - Microsoft Teams

Mar 8, 2026 at 10:38am UTC
Affected services
Microsoft Teams

Resolved
Mar 11, 2026 at 9:16am UTC

Teams email check is now operational and available to all customers.

Created
Mar 8, 2026 at 10:38am UTC

Microsoft Teams email enrichment is currently unavailable. Our team is actively addressing the issue.