Back to overview
Downtime

Email API - Lastfm

Mar 22, 2026 at 02:35pm UTC
Affected services
Lastfm

Resolved
Mar 24, 2026 at 12:01pm UTC

Lastfm email check is now operational.

Created
Mar 22, 2026 at 02:35pm UTC

Lastfm email check is currently unavailable. Our team is actively addressing the issue.