Back to overview
Downtime

Email API - Microsoft Teams

Apr 19, 2026 at 3:22am UTC
Affected services
Microsoft Teams

Resolved
Apr 20, 2026 at 12:11pm UTC

Microsoft Teams email check is now operational.

Created
Apr 19, 2026 at 3:22am UTC

Microsoft Teams email check is currently unavailable. Our team is actively addressing the issue.