Back to overview
Degraded

Email API - Facebook

Jun 8, 2026 at 8:14am UTC
Affected services
Facebook

Resolved
Jun 10, 2026 at 1:30pm UTC

Facebook email check is now operational.

Created
Jun 8, 2026 at 8:14am UTC

Facebook email check is currently operating with reduced accuracy. Our team is actively addressing the issue.