Back to overview
Resolved

Phone API - Microsoft Teams

Jul 18, 2026 at 5:17pm UTC
Affected services
Microsoft Teams (Phone)

Resolved
Jul 18, 2026 at 5:17pm UTC

Microsoft Teams phone check is now operational.